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Introduction

AccuStitch allows you to merge two or more DICOM digital radiographic images 
together. It offers various stitching and blending methods to provide flexibility in stitching 
images obtained from almost any part of the body. Once the images have been joined 
together, the result can be stored as a DICOM file for further analysis.

This section describes:

� possible causes of errors while using the plugin (see “Cautions and warnings” on 
page 3).

� the contents of this guide (see “About this guide” on page 3)

Cautions and warnings
AccuStitch relies on the end user to specify individual fiducial points on each image that is 
being used to create the final stitched image. If these points are not properly placed, the 
resultant stitched image may not indicative of the inherent native data. Therefore, it is 
possible to create images that show structures or malformations, which are not truly 
present in the original image data set.

About this guide
The remainder of this guide consists of the following sections:

� Chapter 2: Getting Started—describes how to install and launch AccuEdit

� Chapter 3: Using AccuStitch—describes how to operate the plugin

� Appendix A: Setting Preferences— describes how to configure the plugin

� Appendix B: Interface Reference—describes the menu items, toolbar buttons, and 
shortcut keys found in the plugin
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Getting Started

This section describes:

� how to install AccuStitch (see “Installing AccuStitch” on page 5).

� launch the AccuStitch plugin (see “Starting AccuStitch” on page 5)

Installing AccuStitch

To install AccuStitch:

� Double-click eFilm_AccuStitch_x.x.exe and follow the installation instructions.

Note: “x.x” represents the current release version number of the plugin.

AccuStitch is installed by simply double-clicking on the self-installing executable file 
provided on the AccuImage software installation disc.

The software license is provided in a software protection device, a hardlock. 

Note: If the hardlock has never been installed on the system before, a hardlock driver 
(provided on the AccuImage CD) must be installed before the software can be used.

Starting AccuStitch
AccuStitch is launched from within your DICOM image viewer.

To start AccuStitch:

1. Start your image viewer.

2. Load the image file that you want to stitch.

3. Start AccuStitch by clicking  and selecting AccuStitch.
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Using AccuStitch

This section describes how to join images using AccuStitch.

To join two images:

1. Select the images to join in the viewer.

2. Launch AccuStitch.

3. You may want to crop the images before joining them (see “Cropping images” on 
page 8).

4. Click . The Stitch Tools dialog box appears.

5. Select one of the stitching options:

� One fiducial (see “Joining using one fiducial” on page 8)

� Two fiducials (see “Joining using two fiducials” on page 9)

� Join two lines (see “Joining using two lines” on page 9)

6. AccuStitch works by having you select corresponding points or lines (depending on 
your chosen joining method) on each image; for example, to join two images using 
one fiducial you would mark a point on the first image, then mark the corresponding 
point on the second image.

To mark a point:

� Position the cursor over the image and left-click to mark the point.

To draw a line:
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Using AccuStitch 
a) At the start of the line, left-click and hold the mouse button.

b) Drag the mouse pointer to the end of the line.

c) Release the left button.

Note: For instructions on adjusting the positions of points and lines you have set, see 
“Moving markers” on page 10.

7. Click Stitch to join the images, or Reset to remove all points and lines to try again.

8. Adjust the images if necessary (see “Adjustment Tools dialog box” on page 18).

9. Choose a blending method to smooth the join between images (see “Blending images” 
on page 10).

10. To add another image to the composite, click  and repeat the steps above.

11. Click  to save the composite image.

Cropping images
You can reduce the size or get rid of the border of images before stitching them together.

To crop images:

1. Click  or select Edit > Crop Image. Dotted yellow borderlines appear. 

2. Specify the area by moving these lines and double-clicking inside the area to apply 
your selection.

3. To toggle between the left and right images, click the image to be cropped or press the 
spacebar to toggle between the two. 

Note: The crop tool will be disabled once the images have been stitched together. Use 
menu item 'Revert' to reset the images back to their original state.

Joining using one fiducial
Mark a point and/or draw a line for each image.

Joining using one fiducial, points only

If only points are drawn, AccuStitch joins point 1 and 2 without rotation.
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Joining using two fiducials
Joining using one fiducial with line

Add a line to the points to make AccuStitch rotate the images. Set one point on each 
image, then draw a line on each image. AccuStitch joins point 1 with point 2 then rotates 
the images so that the two lines are parallel.

Joining using two fiducials
Marking two fiducials allows you to stitch and rotate two images. Mark two points for 
each image to stitch. AccuStitch matches point 1 with point 3, and point 2 with point 4, 
rotating the images as necessary.

Joining using two lines
Draw one line on each image. AccuStitch joins the end of the first line with the start of the 
second, then rotates the images until the lines are parallel.
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Using AccuStitch 
Blending images
To enhance the stitched image quality and flexibility of display, AccuStitch supports five 
blending methods of overlapped area between two images. It can be selected either from 
the Edit menu or right mouse click menu.

The five methods are:

� Blend - smooth transition between two images from 0 to 100%.

� Average - averaged value between two images.

� Differentiate - absolute difference value between two images. This mode is designed 
to enhance the visibility of misregistration during image adjustment.

Tip: It may help to adjust the window/level to enhance the 
overlapped area.

� MIP - on a pixel-by-pixel basis, selects the densest values from the two images.

� MinIP - on a pixel-by-pixel basis, selects the least dense values from the two images.

Moving markers
While the others are displayed as red, only one active marker is displayed in green. You 
can activate any red marker by clicking it. The position of the active marker can be moved 
by using the arrow keys (left/right/up/down). If the 'Shift' key is used in combination, 
movement will be increased by a factor of ten.

To move the active marker by mouse, click and drag the marker to a new location. You can 
also adjust the position of each end of a line this way.
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Setting Preferences

This section describes how to configure AccuStitch. 

The General Preferences menu item is located on the File menu. The General Preferences 
dialog box allows you to set annotation typeface, size, hide stitch animation, select the 
way for saving overlays, and set up resolution change during window/level adjustment.

The following options can be set:

� Line Thickness - specifies the thickness of the line pixel used for overlay drawing in 
pixels.

� Font... - click to choose the typeface and size used for text overlay and measurement.

� Save output file to the following location - select this check box and click Browse... 
to have the image save to a certain fixed location.

� Use patient name as default file name - with this item checked, AccuStitch offers 
patient name as a default file name when saving a file.

� In contrast to saving the overlay as another layer in the DICOM file, you can choose 
the option "Burn overlay into image when save as DICOM" to have the overlay 
drawn into the same layer as image data. This is useful when reviewing the file using 
DICOM viewer that does not support DICOM overlay.

� To save space on the screen, you can hide the animation on tool dialogs.

� Reduce image resolution while adjusting window/level is used to improve visual 
feedback while interactively adjusting the window/level.
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Interface Reference

This section provides a description of the interface elements in AccuStitch. It describes:

� the toolbar buttons (see “Toolbar icons” on page 13)

� the menu items, including keyboard shortcuts (see “Menus” on page 14)

� keyboard shortcuts not associated with toolbar icons or menu items (see “Other 
keyboard shortcuts” on page 16)

� the screen layout (see “Screen layout” on page 17)

� all dialog boxes available in the application (see “Dialog boxes” on page 18)

Toolbar icons
This section describes the functions of each tool on the toolbar.

Toolbar icon Description

Zoom: Hold the left mouse button and 
move the mouse up and down to enlarge/
shrink the image view.

Pan: Hold the left mouse button and move 
the mouse to reposition the image in the 
window.

Window/Level: Hold the left mouse button 
and move the mouse to adjust the 
brightness and contrast of the image.

Inverse Color: Click to reverse the color 
values in the image.

Stitch Tools: Click to display the Stitch Tools 
dialog box.

Next Image: Click to select the next image 
for stitching.

Adjust Image: Click to display the 
Adjustment Tools dialog box.

Crop Image: Click to adjust the size of the 
image in the active window.

Annotate: Click to add text, lines, or 
measurements to the image.

Save: Saves the stitched image in DICOM 
format.
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Interface Reference 
Menus
AccuStitch provides the following menus:

� File (see “File menu commands” on page 14)

� Edit (see “Edit menu commands” on page 14)

� Window (see “Window menu commands” on page 15)

� Help (see “Help menu commands” on page 15)

File menu commands

The following commands are available on the File menu:

Edit menu commands

The following commands are available on the Edit menu:

Command Keyboard shortcut Description

Revert None Discards the stitched image and restarts 
with the original stage.

Save S Saves the stitched image as a DICOM file. 

Print Image Ctrl+P Prints the image on the screen to the 
system printer.

General Preferences None Allows you to set up various options (see 
Appendix A, “Setting Preferences”)

Exit Alt+F4 Closes AccuStitch and returns to the 
viewer. 

Command Keyboard shortcut Description

Zoom Z Engages zoom mode, which allows you to 
enlarge or reduce the size of the image in 
the display by holding the mouse button 
and moving the mouse.

The current zoom factor is shown in the 
title bar above the images.

Pan A Engages pan mode, which allows you to 
reposition the image in the display by 
holding the mouse button and moving the 
mouse. You can also use the scrollbars to 
reposition the images.

Window/Level W Engages window/level mode, which 
allows you to hold the mouse button and 
change the brightness and contrast of the 
image by moving the mouse.

The current window/level values are 
shown in the title bar above the images.
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Menus
Window menu commands

The commands on the Window menu allow you to choose how the plugin will display. 
The following commands are available on the Window menu:

Help menu commands

The following commands are available on the Help menu:

Inverse B Displays current image with inverse 
(negative) values.

Overlay Text Q Toggle patient information on or off.

Stitch Tool T Displays the Stitch Tool dialog box.

Next Image None Adds a new image to the current session.

Adjust Image J Displays the Adjustment Tools dialog box.

Blend method None Selects a blending method for the 
overlapping area between two images.

Annotation N Toggles annotation mode on or off.

Undo Annotation Ctrl+Z Removes the last annotation.

Redo Annotation Ctrl+Y Adds the last removed annotation.

Clear Annotations Ctrl+C Removes all annotations.

Command Keyboard shortcut Description

Fit Window to Viewer None The viewer window and toolbar are not 
visible. The AccuStitch window fits over 
the main viewer window.

Fit Window to Viewer’s 
client

None The viewer window and toolbar are visible 
and active. The AccuStitch window fits 
inside the viewer window.

Fit to Viewer on startup None Sets the AccuStitch window to fit over the 
viewer on start-up.

Fit to Viewer’s client on 
startup

None Sets the AccuStitch window to fit inside 
the viewer window on start-up.

Show Toolbar None Toggles the display of the toolbar.

Command Keyboard shortcut Description

Help Topics None Displays the online help.

Quick Start Tips None Displays a short list of tips for getting 
started with the plugin (also shown at 
startup).

About AccuStitch None Displays information about the plugin.

Command Keyboard shortcut Description
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Interface Reference 
Other keyboard shortcuts
This section describes keyboard shortcuts that are not tied directly to menu items or 
toolbar icons:

� annotation tools (see “Annotation commands” on page 16)

� keys available in Stitch Tools mode (see “Stitch Tools mode” on page 16)

� keys available in Adjust Image mode (see “Position adjustment mode” on page 17)

Annotation commands

This section describes keyboard shortcuts that activate annotation/measurement tools.

Stitch Tools mode

This section describes the keyboard shortcuts available while the Stitch Tools dialog box is 
displayed.

Key Description

D Activate Distance measurement tool 

E Activate Ellipse annotation tool

F Activate Freehand annotation tool

G Activate Angle measurement tools 
on-off

K Activate Cobb angle measurement 
tool

L Activate Line annotation tool

N Toggles Annotation/Measurement 
Tools on-off

Key Description

Up Moves selected marker up one pixel

Down Moves selected marker down one 
pixel

Left Moves selected marker left one pixel

Right Moves selected marker right one pixel

Note: If a 'Shift' key is used in combination, movement will be increased by a 
factor of ten.
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Screen layout
Position adjustment mode

This section describes the keyboard shortcuts available while the Adjust Image dialog box 
is displayed.

Screen layout
The AccuStitch screen is laid out with a toolbar across the top and the images to be joined 
below. The title bar for the plugin includes the patient name. The title bar for the images 
displays the current Window/Level and Zoom factor settings.

Key Description

Up Moves high-lighted item up one pixel

Down Moves high-lighted item down one 
pixel

Left Moves high-lighted item left one pixel

Right Moves high-lighted item right one 
pixel

Page Up Rotate image one degree anti 
clockwise

Page Down Rotates image one degree clockwise

Note: If a 'Shift' key is used in combination, movement will be increased by a 
factor of ten.
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Interface Reference 
Dialog boxes
This section describes the major dialog boxes available in AccuStitch:

� Stitch Tools (see “Stitch Tools dialog box” on page 18)

� Adjust Image (see “Adjustment Tools dialog box” on page 18)

� Annotate tools

Stitch Tools dialog box

The Stitch Tools dialog box allows you to select a stitching method and stitch two images 
together.

Note: If you want to crop either image, you should do so before stitching images.

The following options are available:

� One fiducial - mark a point and/or draw a line for each image to stitch. 

� Two fiducials - mark two points for each image to stitch. 

� Join two lines - draw a line for each image. 

� Reset - reset all points and lines and start all over again. 

� Cancel - close the Stitch Tools dialog. 

� Stitch - begin stitching process once all appropriate points and/or lines have been 
drawn.

Adjustment Tools dialog box

The Adjustment Tools dialog box allows the user to adjust position, contrast and gradient of 
the stitched image.
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Dialog boxes
The following options are available:

� Position - adjust image position and rotation. 

� Contrast - adjust contrast of one image.

� Gradient - smoothly adjust contrast of both images.

� Reset - reset parameters of current mode back to the original. 

� Cancel - cancel change and close the tool. 

� Accept - accept change and close the tool.

Position Adjustment

The image can be moved one pixel each stroke by using left/right/up/down keys. The 
rotation is changed one degree each stroke by using PageUp/PageDown keys. If a 'Shift' 
key is used in combination, movement will be increased by a factor of ten.

To move the center-of-rotation (red cross-mark in picture), apply one click on top of it. 
Once it has changed from red to green, you can drag it to another position by using the 
same method as moving marker.

Contrast Adjustment

When images have different window/level settings, use the contrast adjustment tool to 
reduce the differences.

To adjust the contrast of an image:

1. Click the Contrast button.

2. Left click inside the border of the image and drag the mouse up/down to adjust the 
level and left/right to adjust the window settings.

Note: The window/level settings are shown in the title bar.
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Interface Reference 
Gradient Adjustment

The gradient tool works in combination with the contrast adjustment. To adjust the 
contrast of the image, left click inside the border and drag the mouse up/down to adjust 
level and left/right to adjust window.

Once the contrast adjustment is completed, the gradient will be applied afterward. The 
default gradient range starts from the center of one image to the center of the other image. 
These are represented as dots on the images. To modify the range, left click on either one 
of the dots and drag it to a new position.

Annotate

The annotation tools allow you to label images with text as well as draw lines, freehand 
shapes, and ellipses to pinpoint or circle specific structures. When activated, the 
annotation tools dialog appears.

The following tools are available:

Command Keyboard Shortcut Description

Line L Draw a straight line between two 
points. Once you have finished one 
line, the next line will be started 
automatically at the end of the first 
line. Right-click to cancel the drawing 
at any time.

Ellipse E Draw an ellipse between two points.

Freehand F Draw a continuous line along the 
mouse movement.

Text None Click to select the location where the 
text should be drawn. The text input 
dialog will appear. The point where 
you clicked always forms the left 
margin of the text.

Distance D Allows you to draw a straight line 
between two points and have the 
distance between them calculated. The 
distance value could be left empty if 
the DICOM file does not include the 
pixel size value.

Line

Freehand

Distance

Angle

Cobb

Text

Ellipse
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Dialog boxes
Note: Line thickness, size and style of font (or typeface), can be set from the General 
Preferences dialog box (see Appendix A, “Setting Preferences”).

Angle G Click three times to form an angle. The 
maximum measurable angle is 180°.

Cobb K Used to measure scoliosis and sagittal 
curvature. Two lines are required to 
measure using the Cobb method. The 
maximum measurable angle using the 
Cobb method is 90°.

Command Keyboard Shortcut Description
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